DOC HOME SITE MAP MAN PAGES GNU INFO SEARCH PRINT BOOK
 
HDK Technical Reference

Packaging and installing SVR5 drivers

The driver package consists of the compiled driver object file and the DSP (Driver Software Package). files that the system uses to install and configure the driver on the target system. See ``DSP (Driver Software Package)''.

For information about packaging SCO OpenServer 5 drivers, see ``Packaging SCO OpenServer 5 drivers for installation''.

Installing drivers

Use the following tools to install and configure drivers:

Tool Description
idinstall Install driver and configuration files. idinstall calls idresadd to update the resource manager with information from the System(DSP/4dsp) file.
idbuild Configure/rebuild new kernel with newly installed (or removed) driver
idtune Set value for tunable driver parameters

Use the pkgmk command to create a DSP package that contains all the driver component files. Then, use the pkgtrans command to transfer the package to the destination media (usually a floppy disk).

Deferred and immediate builds

Once your loadable driver is installed, the next step is to configure it into the system using the idbuild command.

There are two ways you can configure your loadable driver using idbuild: a deferred build and an immediate build:


deferred build
If you don't want to configure your driver into the system that is currently running, invoke idbuild with no options, and the driver will be configured on the next reboot.

When no options are given, the idbuild command does not rebuild the kernel. It simply sets a rebuild flag and exits. The next time the system is rebooted, the reboot process rebuilds the kernel and reconfigures all modules flagged as loadable.


immediate build
If you do want to configure your loadable driver into the running system immediately, invoke idbuild with the -M option. This option configures your loadable driver into the system immediately, without a reboot.

Some of the tasks the -M option performs to configure your loadable driver include placing the driver's loadable image in the /etc/conf/mod.d directory, and creating the necessary nodes in the /dev directory. If your DSP contains an Init(DSP/4dsp) component, idinstall adds and activates your driver's inittab entries; they will take effect the next time the system's init state changes. idbuild also registers your driver with the kernel to make it available to the rest of the system.

The -S option is available to configure drivers as if all had been marked as static, and not loadable. If this option is specified, all the modules are treated as static modules. Use of this option does not prevent the configuration of any newly installed loadable modules later.

Packaging drivers

SVR5 drivers are packaged with the pkg* tools. SCO OpenServer 5 drivers can be packaged with either the CDMT tools or, for SCO OpenServer Release 5.0.5a and later, can use the SVR5 pkg* tools.

This article summarizes the packaging facilities for SVR5. For more information, see:

The SVR5 packaging tools include a set of commands that work with a set of specifically-named files. See ``Packaging your software applications'' for general information about using these tools.

The packaging tools are:


pkgmk(1)
Create a DSP package that contains all the driver component files.

pkgtrans(1)
Transfer the package to the destination media (such as a floppy disk).

pkgadd(1M)
Install the DSP on a target system. The pkgadd command takes the installable DSP (executing an optional request script, if present) and runs the preinstall script. Next, the postinstall script is run. This runs idinstall to install the driver files, and, for drivers that use DDI versions prior to DDI 8, idtune to set any required tunable variables. idbuild is then called to rebuild the kernel. If necessary, the system is shut down and rebooted at this point.

pkgrm(1M)
Remove the DSP from a target system.

The packaging commands use the following files:


prototype(4)
List the DSP contents to be installed.

preinstall
Script to run before the DSP is installed.

postinstall
Script that installs the DSP and driver.

preremove
Script to remove the driver from the system in an orderly fashion.

© 2005 The SCO Group, Inc. All rights reserved.
OpenServer 6 and UnixWare (SVR5) HDK - June 2005